Forums
uPanel and Arduino - Signal issues - Printable Version

+- Forums (http://www.miupanel.com/forum)
+-- Forum: μPanel (http://www.miupanel.com/forum/forumdisplay.php?fid=1)
+--- Forum: Microcontroller Side (http://www.miupanel.com/forum/forumdisplay.php?fid=15)
+--- Thread: uPanel and Arduino - Signal issues (/showthread.php?tid=158)



uPanel and Arduino - Signal issues - antimix - 09-15-2016

Hi,

I have some questions about the serial signal and uPanel.

1) I read on the guide that the TX (uPanel Pin) should be disconnected during Arduino programming in IDE.

- Just because the serial interface is shared between the IDE programmer and the uPanel, and signal sent back from uPanel can scramble the byte codes that are sent to the ATmega chip ?

- Is it better to disconnect both the TX & RX pin on uPanel during Arduino Programming ?


2) The standard baud rate of the Arduino sketch is always 9600, and so also the programming serial speed.
    In order to talk with the uPanel , I have changed my scripts to a Serial.Begin(57600).

- I got a side effect, even with uPanel Pin TX disconnected: a lot of random garbage at Arduino programming, with several error and fatal fail messages. I imagine that it is caused by the fact that my script set the serial at a different baud rate than the IDE programming task, causing communication  conflicts and serial garbage.
- Yesterday after a couple of programming error, the virtual serial port vanished, and I was not able any more to access to the Arduino. Huh 
I was convinced to have killed the arduino or the boot loader, but thanks to Google I solved the issue. It is a bug in the IDE interface, and after several programming error he tried to auto-configure and do something that geopardize the setup. Just selecting a different programmer, AND THAN, back the arduino board, I was able to access to the arduino again. Scary Confused

Today I have configured uPanel to 9600 just to see what happen. It is not important the speed duing the develop phase if this avoid to scramble the IDE at each programming. I will see what happen.


Any experience on those issues ?

Regards


RE: uPanel and Arduino - Signal issues - romoloman - 12-26-2016

I suggest you to use SoftSerial and avoid using hardware serial port on platforms that only have one hw serial port (it's different on Mega or ATMEGA32U4 based arduinos that may use Serial1 to communicate with the module. Software serial is quite efficient in handling uPanel communications and avoid connecting and disconnecting the module at each arduino software upgrade.
If you need more than one data flow use AltSoftSerial


RE: uPanel and Arduino - Signal issues - Technomaker - 12-28-2016

Dear antimix,
1) you have to disconnect the RX (pin D0) of Arduino UNO because during upload of the sketch the IDE transmit to Arduino through that serial port. This does not depend from the miuPanel module, it is a general practice to do. The TX pin of Arduino is not important during the sketch upload.

2) Here, you make confusion! You have confused the "standard baudrate during upload if the sketch" (you have not change this settings!) with the baudrate in your sketch used for your application (Serial.Begin(57600))! This are two different things.