Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problemi con pannello
#1
Ciao a tutti,
a volte capita che passati un paio di giorni, il modulo rimane raggiungibile da remoto ma il pannello non viene recuperato.
Anche con il semplice sketch d'esempio per comandare un relè:
Code:
void setup() {

 // Initialize Serial Port
 Serial.begin(57600);
 
 // Let uPanel start
 delay(3000);

 // Discharge old partial messages
 Serial.println("");
 
 // Send The Panel (A LED and a Switch)
 Serial.println("$P:D!282;T*15:Arduino Relay;=*20/L1G:0:Relay;/+*10W1:0;");

 // Initialize digital output pin
 digitalWrite(8, 1);
 pinMode(8,OUTPUT);
 
}

String Msg;

void loop() {
 
 int c;
 while ((c = Serial.read()) > '\n') Msg += (char) c;  // Read incoming chars, if any, until new line
 if (c == '\n')                                       // is the message complete?
 {
   if (Msg.equals("#W10")) {digitalWrite(8,1); Serial.println("#L10");}    // Turn OFF LED 1 and Relay if switch is OFF
   if (Msg.equals("#W11")) {digitalWrite(8,0); Serial.println("#L11");}    // Turn ON LED 1 and Relay if switch is ON
   Msg = "";
 }
   
}

Come si puo' risolvere?
Ciao
Enzo

Reply


Messages In This Thread
problemi con pannello - by Enzo147 - 12-28-2016, 12:42 PM
RE: problemi con pannello - by Enzo147 - 12-28-2016, 09:56 PM
RE: problemi con pannello - by Technomaker - 01-14-2017, 06:20 PM
RE: problemi con pannello - by Enzo147 - 01-15-2017, 10:45 AM
RE: problemi con pannello - by Enzo147 - 01-17-2017, 06:17 PM
RE: problemi con pannello - by Enzo147 - 01-17-2017, 07:26 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)