Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Termostato via Internet.
#11
(05-10-2016, 08:09 PM)MAO Wrote:
(05-10-2016, 04:56 PM)enrico1058 Wrote: Scusa se tento di approfittare dei tuoi progressi, ma a che punto sei arrivato?

Perchè io sono in grosse difficoltà perchè le stringhe che disegnano il pannello funzionano sul simulatore e poi non funzionano sul modulo.

Ad esempio scrivere "Umidità (%)" non pare possibile perchè da errore; su "Temperatura (°C)" ho risolto mettendo nella stinga "&deg" al posto di "°" ma sul "%" nulla di fatto.

Puoi dare una mano?

Grazie per l'attenzione

Enrico

Ciao Enrico,

io ho appena fatto uno sketch simile, e la  % mi funziona senza problemi...ho avuto lo stesso tuo problema con "°" che ho risolto nel tuo stesso modo.
il firmware di upanel l'hai aggiornato all'ultima versione?
Te lo chiedo perchè io ce l'ho aggiornato e la % mi funziona.
Fammi sapere


Ciao.

Ho provato ad eseguire un update del firmware ma ho ottenuto:

"Alert - Firmware upgrade is currently not allowed on your product"

e spero che non sia ammesso perché non ci sono aggiornamenti da fare.

Anche l'app è alla versione 1.0.27, e non mi pare ce ne siano di più recenti.

Ora provo a contattare il produttore.....

Il produttore conferma che il firmware è aggiornato.
Mi ha mandato una stringa ulteriore con "%" sostituito da "(&#37)" e non riuscivo a farla andare finché non mi è venuto in mente di eliminare la "à" di "Umidità" e scrivere "Umidita"
Ora almeno posso continuare, la grammatica del pannello è secondaria.....
Reply
#12
(05-14-2016, 07:11 PM)enrico1058 Wrote:
(05-10-2016, 08:09 PM)MAO Wrote:
(05-10-2016, 04:56 PM)enrico1058 Wrote: Scusa se tento di approfittare dei tuoi progressi, ma a che punto sei arrivato?

Perchè io sono in grosse difficoltà perchè le stringhe che disegnano il pannello funzionano sul simulatore e poi non funzionano sul modulo.

Ad esempio scrivere "Umidità (%)" non pare possibile perchè da errore; su "Temperatura (°C)" ho risolto mettendo nella stinga "&deg" al posto di "°" ma sul "%" nulla di fatto.

Puoi dare una mano?

Grazie per l'attenzione

Enrico

Ciao Enrico,

io ho appena fatto uno sketch simile, e la  % mi funziona senza problemi...ho avuto lo stesso tuo problema con "°" che ho risolto nel tuo stesso modo.
il firmware di upanel l'hai aggiornato all'ultima versione?
Te lo chiedo perchè io ce l'ho aggiornato e la % mi funziona.
Fammi sapere


Ciao.

Ho provato ad eseguire un update del firmware ma ho ottenuto:

"Alert - Firmware upgrade is currently not allowed on your product"

e spero che non sia ammesso perché non ci sono aggiornamenti da fare.

Anche l'app è alla versione 1.0.27, e non mi pare ce ne siano di più recenti.

Ora provo a contattare il produttore.....

Il produttore conferma che il firmware è aggiornato.
Mi ha mandato una stringa ulteriore con "%" sostituito da "(&#37)" e non riuscivo a farla andare finché non mi è venuto in mente di eliminare la "à" di "Umidità" e scrivere "Umidita"
Ora almeno posso continuare, la grammatica del pannello è secondaria.....

Dopo aver eseguito aggiornamento fitmware e pannello sullo smatphone direi che ci siamo; scrive à, è, % e ° senza ricorrere a codici.

Ora ho una domanda leggera: come posso incorporare un punto decimale in un display a tre cifre?

Penserei di usare un LED tipo: 

D!00A-k;L15:2;L25:1;L30G*4b:1;L45:6; 

ma il punto si posiziona al centro nonostante la "b" di bottom (e non cambia con "t" di top).

Qualche idea?

Grazie per l'attenzione

Enrico
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)