Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SCF-TOP03 Difficoltà connessione internet [risolto]
#1
Ho un SCF-TOP03 su cui riesco a far girare senza problemi i vari esempi
più semplici (led, bottone ecc.)

Ho provato 4 cellulari (1 IOS, 2 Android 4.4 e il mio android 5.1).
Tutti si connettono sia direttamente che tramite rete locale WIFI senza problemi.
Sul router ho aperto la porta 80 e 81 con 9337 e 9338.
Nella finestra di start appare correttamente:

           00d9e173
    click here to connect
         192.168.0.188
 188.10.93.32(9337,9338)

Via internet (spegnendo il WIFI dei CELL) si connettono regolarmente 
sia IOS che i 2 Android 4.4 (quelli degli altri).
Il mio con Android 5.1 (un Nexus 5) non si connette.
Qualche volta facendo 'Locate in Cloud', ricevo: 'Alert   Data received successfully from Cloud',
si connette una prima volta (non sempre) e funziona normalmente.
Se chiudo l'App µPanel e la riapro, non va più.

Quando non va, indica
'Connecting through internet with    00d9e173    please wait'
e poi  'Connection with 00d9e173 failed'

Anche facendo 'Locate in Cloud' dice 
'Discovering product location through cloud. Please wait.
e poi 'Connection with 00d9e173 failed'.

Ho provato di tutto, e speso molto tempo; ora non so dove guardare.

Può dipendere da android 5.1 o dal mio cell. ?

Grazie

elvisee

Addendum:
Ho inserito la SIM del mio cell. su un vecchio Android 2.3.7 e funziona
regolarmente, quindi non credo dipenda dal provider 3G.
Il mio cell per il resto funziona regolarmente.....e molto bene..
Reply
#2
(04-04-2016, 04:41 PM)elvisee Wrote: Ho un SCF-TOP03 su cui riesco a far girare senza problemi i vari esempi
più semplici (led, bottone ecc.)

Ho provato 4 cellulari (1 IOS, 2 Android 4.4 e il mio android 5.1).
Tutti si connettono sia direttamente che tramite rete locale WIFI senza problemi.

[cut]

Il mio cell con Android 5.1 (un Nexus 5) da 3G non si connette.

[cut]
Aggiornamento:
Prima il cell con android 5.1 non si connetteva da 3G, mentre gli altri si.
Dopo un po' di giorni non si connettevano nemmeno gli altri,
mentre via LAN sempre tutto perfetto.

Ho finalmente scoperto uno dei problemi di connessione da 3G:
Il router Telecom in DHCP non riesce a sposare l'IP che assegna,
anche se impostato come 'assegnato', ma a volte lo cambia di sua iniziativa.
Questo fa si che MAC Address --> IP --> porta interna --> porta esterna
non combaciano più, e quindi non riesce ad accedere.


Non mi spiego perché se da un luogo remoto col cell mi connettevo ad
una WI-FI Zone (non 3G), riuscivo tranquillamente ad acccedere al modulo,
ma può darsi che per coincidenza l'IP in quel momento fosse quello giusto.

Ora, dopo numerosi tentativi di associare l'IP al MAC Address, il router sembra
mantenerlo, ma attendo verifica nel tempo.

elvisee
Reply
#3
[quote pid='249' dateline='1460229457']
2° Aggiornamento:
Dopo molte prove ho visto che, se non attivo la configurazione automatica
del router 'Enable Router Conf.' , funziona.
Se invece attivo la spunta, pur essendo tutto corretto non si connette più.

elvisee
[/quote]
Reply
#4
sul modulino su qui sto lavorando , ho fatto ieri l'aggiornamento alla v4, poi da remoto ho provato a rinominare dal menu configurazione 
AP SSID e da quel momento ho perso il collegamento

questa mattina ho rifatto varie prove con cloud o non cloud , ma niente, alla fine ho scoperto che rinominando AP SSID mi aveva 
perso la configurazione IP statico, poi ho fatto delle contro prove questa mattina, non mi cambiava l'ip statico
ma comunque da remoto una volta cambiato AP SSID a volte non si connetteva piu
ho scoperto che riprendeva il collegamento riconfermando con gli ok IP locale e remoto della pagina iniziale dell'App

Comunque suggerirei di poter mettere come protect anche i comandi AP SSID ed in particolar modo il comando
Router "enable connection" che se innavertitamente deflaggato rende il modulo irragiungibile
Reply
#5
(05-28-2016, 06:59 AM)Lorix Wrote: sul modulino su qui sto lavorando , ho fatto ieri l'aggiornamento alla v4, poi da remoto ho provato a rinominare dal menu configurazione 
AP SSID e da quel momento ho perso il collegamento

questa mattina ho rifatto varie prove con cloud o non cloud , ma niente, alla fine ho scoperto che rinominando AP SSID mi aveva 
perso la configurazione IP statico, poi ho fatto delle contro prove questa mattina, non mi cambiava l'ip statico
ma comunque da remoto una volta cambiato AP SSID a volte non si connetteva piu
ho scoperto che riprendeva il collegamento riconfermando con gli ok IP locale e remoto della pagina iniziale dell'App

Comunque suggerirei di poter mettere come protect anche i comandi AP SSID ed in particolar modo il comando
Router "enable connection" che se innavertitamente deflaggato rende il modulo irragiungibile

Buongiorno Lorix,

non è chiaro se sia il suo caso, ma tenga presente che quando si salva una nuova configurazione dal menu della App, tutte le connessione vengono inizializzate, quindi occorre attendere qualche decina di secondi prima che il modulo si ricolleghi al router e poi al Cloud.

Esiste il comando $APP-CLIMSET che permette di impostare in modo selettivo quali gruppi di funzioni disabilitare da App tra quelle collegate a: Hardware, Access Point, Router, Configurazione.

Ad esempio bloccando i comandi router, verranno disabilitati i comandi: $CONNECT, $DISCONNECT, $ROUTER, $NOROUTER

Oppure bloccando i comandi di configurazione non sarà più possibile nemmeno accedere al menu di configurazione del modulo. 

La pagina dei comandi è disponibile al link:

http://www.miupanel.com/Wi-Fi-Module/MODULE-COMMANDS
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)